Can't log in with Facebook Connect

Andrew's Avatar

Andrew

06 Dec, 2012 05:07 PM

I just installed the Untappd native Android app from the Google Play store. I attempted to log in using facebook connect. The app opens a browser window and allows me to log in to facebook. After I do so, the in-app browser asks for optional permissions (which I denied by pressing the "Skip" button in the upper-left). At that point, the app's browser just displays the text "Success" and sits there. Using the X in the upper-right corner then brings me to the App's login screen. Pressing the connect with facebook button again at that point just takes me back to the optional permissions page again, and then the "Success" page.

I've tried denying the permissions via "Allow None", Allowing them with "Allow All" and I've also gone into Android's app settings and used the "Clear Cache" and "Force Stop" buttons to troubleshoot.

  1. Support Staff 1 Posted by Greg Avola on 06 Dec, 2012 05:12 PM

    Greg Avola's Avatar

    If we don't have permission to access your account, you can't "Sign up or Login w/ Facebook". (basically you have to "Allow" instead of "Skip"). We would have no idea who you were to authenticate you. We NEVER post to your wall without your permission.

    Does this make sense - let me know!

    Thanks,
    Greg

  2. 2 Posted by Andrew on 06 Dec, 2012 05:28 PM

    Andrew's Avatar

    Sorry, maybe I wasn't being clear enough.

    I'm giving the login permissions on the first screen - there are options for "install" and "cancel" there and I'm choosing "Install". After I do so, Untappd appears on my list of apps in Facebook > Account Settings > Apps.

    I've also tried both allowing and denying the optional permissions that come after the login screen. Neither option works. The app doesn't seem to log in to facebook, it just hangs on that "Success" page.

  3. Support Staff 3 Posted by Greg Avola on 06 Dec, 2012 05:53 PM

    Greg Avola's Avatar

    Andrew,

    Are you trying to sign up for an account or just "log-in"?

    I got confused when you said this line: "After I do so, the in-app browser asks for optional permissions (which I denied by pressing the "Skip" button in the upper-left). ". I you Skip all permissions - nothing will happen.

    I just tested this on iOS and it seemed to work fine - looking around for an Android device to test.

    Thanks.
    Greg

  4. 4 Posted by Andrew on 06 Dec, 2012 06:06 PM

    Andrew's Avatar

    Just log in. Buttons on the front page are

    "Log in" "Connect with facebook" === OR === "Sign Up"

    I'm pressing the "Connect with Facebook" option. I just heard about the app so I don't have an account. I was hoping to avoid making an account by using the facebook login.

  5. Support Staff 5 Posted by Greg Avola on 06 Dec, 2012 06:10 PM

    Greg Avola's Avatar

    Andrew,

    Sorry for the confusion - this is very strange. Even if you "create an
    account with Facebook" you will still need to create another account on
    Untappd (but it will import your information to make the setup easier).

    Do you think you can try re-installing the app and tying again? I'll try to
    figure out what the issue is. Can you copy and paste the URL that is shown
    in the URL address bar?

    Thanks,
    Greg

  6. 6 Posted by Andrew on 06 Dec, 2012 06:19 PM

    Andrew's Avatar

    Sure, I can try a reinstall.

    So I can't just "Connect with Facebook"; I need to create an account using the "Sign Up" button first? Or is my choosing the connect button a valid way to get into the app the first time - e.g., it'll make me an account that way?

    Unfortunately, I can't seem to copy that URL. I can touch the URL box but a long press doesn't bring up the copy/paste dialog. It's something like:
    https://www.facebook.com/connect/login_success.html#access_token=&expires_in=&code=

  7. Support Staff 7 Posted by Greg Avola on 06 Dec, 2012 07:06 PM

    Greg Avola's Avatar

    Hey Andrew,

    To use Untappd - you need to create a new account. We make the process a little easier - by sucking in all your information (first name, last name, email etc) into the registration page so you don't have to do that. Our log-in mechanism is very different than Facebook and we didn't want to be tied down in case they change it. Our "connect with Facebook" simply makes sign-up easier and once you create an account you can just click "Connect with Facebook" to log-in in the the future.

    It doesn't seem that the URL is wrong, so I'll need to dig deeper - try a re-install and let us know.

    Thanks,
    Greg

  8. 8 Posted by Andrew on 06 Dec, 2012 07:28 PM

    Andrew's Avatar

    No luck with the reinstall - same exact problems.

    I didn't want FB to post stuff on my wall, I just hate making new accounts for every app and thought fb-connect could help me get past that. I'll probably just start over without attempting to connect to Facebook.

    Thanks for your help, Greg! Good luck squashing that bug. FYI: I was using a Galaxy Nexus on Android 4.1.2.

    • Andrew
  9. Support Staff 9 Posted by Greg Avola on 11 Dec, 2012 02:44 PM

    Greg Avola's Avatar

    Andrew,

    Just so you know - we've fixed this problem and aim to update the app tomorrow. Cheers!

    Thanks,
    Greg

  10. 10 Posted by brandie bullock on 23 May, 2013 03:58 AM

    brandie bullock's Avatar

    I'm having same proplem now I've played the game for months and was on level22 and today when I tried to connect with facebook it keeps sending me to that website and saying webpage is no longer avaliable and I've uninstaled and it doing to same thing

  11. Support Staff 11 Posted by Greg Avola on 23 May, 2013 04:12 AM

    Greg Avola's Avatar

    Level 22? Are you this is for Untappd and not another game? If not, can you
    please provide a screenshot?

    Greg

  12. 12 Posted by Amy on 10 Jul, 2013 04:45 PM

    Amy's Avatar

    hi, i have a Alcatel OT 916d and it keeps notifying me to allow the f button on the phone to make the phone more social when i allow it it says the website could not be found... help please :)

  13. Support Staff 13 Posted by Greg Avola on 10 Jul, 2013 04:50 PM

    Greg Avola's Avatar

    Is this an Untappd issue? This forum is only for Untappd support issues.
    Check with Facebook for more information!

    Greg

  14. 14 Posted by Melissa Haslip on 18 Jul, 2013 08:09 PM

    Melissa Haslip's Avatar

    I can't connect to Facebook to candy crush game please help me

  15. Support Staff 15 Posted by Greg Avola on 18 Jul, 2013 08:14 PM

    Greg Avola's Avatar

    We are not support for Candy Crush. I recommend checking out their support site.

    Greg

    Sent from my iPhone

  16. 16 Posted by muero on 17 Oct, 2013 06:46 AM

    muero's Avatar

    Hi, i have a Alcatel 916, very time i on my data or wi-fi it keep notifying about the F button, social networking,and than it says accept or skip, when i press Accept, it loads and than says "this page is broken or expired" (this is after i log in to facebook)

  17. 17 Posted by muero on 17 Oct, 2013 06:48 AM

    muero's Avatar

    Please help

  18. Support Staff 18 Posted by Greg Avola on 17 Oct, 2013 12:15 PM

    Greg Avola's Avatar

    Can you take a screenshot of what your seeing? That's the best way to
    troubleshoot the issue. Thanks!

    Greg

  19. 19 Posted by Andrew K on 16 Jul, 2014 11:46 PM

    Andrew K's Avatar

    Error says I cancelled the log in to facebook, but I have not. Happens on now my second device with untappd installed.

  20. 20 Posted by acai on 10 Oct, 2014 02:06 PM

    acai's Avatar

    i cant sign up thourgh line app, i dont know wht happen, i try to sign up with fb also dosent happen, still loading... can some one tell me wht happen

  21. Support Staff 21 Posted by Greg Avola on 10 Oct, 2014 02:24 PM

    Greg Avola's Avatar

    I'm not sure I understand what the issue is - can you provide a screenshot
    or detailed error of the problem you are having?

    Greg

  22. 22 Posted by Melissa Haslip on 10 Oct, 2014 09:41 PM

    Melissa Haslip's Avatar

    I didn't send this email. Not sure what this is about.

    Sent from Yahoo Mail on Android

  23. Support Staff 23 Posted by Greg Avola on 10 Oct, 2014 09:45 PM

    Greg Avola's Avatar

    Melissa - you can remove yourself here: http://help.untappd.com/discussions/problems-with-untappd-native-fo...

    You sent in a request a long time ago.

    Greg

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac